[kernel] refresh 2.6.26 patches
[openwrt/svn-archive/archive.git] / target / linux / ar7 / patches-2.6.26 / 110-flash.patch
index 4740e3421e4c14f038ce80bf42d6061df0657dc5..bda6e3727cd11db7c9932aabe9ba57e321cb028f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/Kconfig
 +++ b/drivers/mtd/Kconfig
-@@ -174,6 +174,12 @@
+@@ -174,6 +174,12 @@ config MTD_AR7_PARTS
        ---help---
          TI AR7 partitioning support
  
@@ -15,7 +15,7 @@
  config MTD_CHAR
 --- a/drivers/mtd/Makefile
 +++ b/drivers/mtd/Makefile
-@@ -13,6 +13,7 @@
+@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdli
  obj-$(CONFIG_MTD_AFS_PARTS)   += afs.o
  obj-$(CONFIG_MTD_AR7_PARTS)   += ar7part.o
  obj-$(CONFIG_MTD_OF_PARTS)      += ofpart.o
@@ -25,7 +25,7 @@
  obj-$(CONFIG_MTD_CHAR)                += mtdchar.o
 --- a/drivers/mtd/maps/physmap.c
 +++ b/drivers/mtd/maps/physmap.c
-@@ -87,7 +87,8 @@
+@@ -87,7 +87,8 @@ static int physmap_flash_remove(struct p
  
  static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
  #ifdef CONFIG_MTD_PARTITIONS