[ar7] refresh patches
[openwrt/svn-archive/archive.git] / target / linux / ar7 / patches-2.6.32 / 920-ar7part.patch
index e4ad09f2d8d20ff36d6148177e2ee506ce8f9df3..84958551be9e8c561021211760572288b2e4e947 100644 (file)
@@ -1,5 +1,5 @@
---- a/drivers/mtd/ar7part.c-back       2010-01-13 15:58:44.000000000 -0500
-+++ b/drivers/mtd/ar7part.c    2010-01-13 16:16:05.000000000 -0500
+--- a/drivers/mtd/ar7part.c
++++ b/drivers/mtd/ar7part.c
 @@ -27,12 +27,14 @@
  #include <linux/mtd/partitions.h>
  #include <linux/bootmem.h>
@@ -26,7 +26,7 @@
  static int create_mtd_partitions(struct mtd_info *master,
                                 struct mtd_partition **pparts,
                                 unsigned long origin)
-@@ -57,6 +63,16 @@ static int create_mtd_partitions(struct 
+@@ -57,6 +63,16 @@ static int create_mtd_partitions(struct
        int retries = 10;
        struct mtd_partition *ar7_parts;
  
@@ -43,8 +43,8 @@
        ar7_parts = kzalloc(sizeof(*ar7_parts) * AR7_PARTS, GFP_KERNEL);
        if (!ar7_parts)
                return -ENOMEM;
---- a/drivers/mtd/Makefile     2010-01-11 14:44:12.000000000 -0500
-+++ a/drivers/mtd/Makefile     2010-02-03 13:44:38.000000000 -0500
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
 @@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
  obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
  obj-$(CONFIG_MTD_AFS_PARTS)   += afs.o