[ar71xx] simplify setup code for Ubiquiti boards
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / Makefile
index 6bf277a1097f65b50fa5b700400fe6d5323998f2..07792ffdd43e3f7560ea33a1f93da038a5442fe9 100644 (file)
@@ -8,17 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx
+BOARDNAME:=Atheros AR71xx/AR913x
 FEATURES:=squashfs tgz
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
 LINUX_VERSION:=2.6.28.7
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
+DEFAULT_PACKAGES += \
+       kmod-gpio-leds kmod-input-core kmod-input-polldev \
+       kmod-input-gpio-buttons kmod-button-hotplug
 
 define Target/Description
-       Build firmware images for Atheros AR71xx based boards
+       Build firmware images for Atheros AR71xx/AR913x based boards.
 endef
 
 $(eval $(call BuildTarget))