kernel: update kernel to version 2.6.39.4
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / Makefile
index ab1dab582a93910f0ee513824a87e698d401dd7e..0925d9c3c2dccd05e71b8169cbc4d5a05f70163f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,20 +8,21 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR7240/AR913x
-FEATURES:=squashfs jffs2 tgz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+BOARDNAME:=Atheros AR71xx/AR7240/AR913x/AR934x
+FEATURES:=squashfs jffs2 targz
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+SUBTARGETS:=generic nand
 
-LINUX_VERSION:=2.6.32.9
+LINUX_VERSION:=2.6.39.4
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-buttons kmod-button-hotplug swconfig
+       kmod-input-gpio-keys-polled kmod-button-hotplug swconfig
 
 define Target/Description
-       Build firmware images for Atheros AR71xx/AR913x based boards.
+       Build firmware images for Atheros AR71xx/AR913x/AR934x based boards.
 endef
 
 $(eval $(call BuildTarget))