ar71xx: disable jffs2 by default, it confuses users since many devices have incompati...
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / Makefile
index 6bf277a1097f65b50fa5b700400fe6d5323998f2..69301a96ee5956c70492425901fe7da93d060cd5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,22 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx
-FEATURES:=squashfs tgz
+BOARDNAME:=Atheros AR7xxx/AR9xxx
+FEATURES:=squashfs targz mips16
+CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -fno-caller-saves -mno-branch-likely
+SUBTARGETS:=generic nand
 
-LINUX_VERSION:=2.6.28.7
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug kmod-wdt-ath79 swconfig \
+       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
+       kmod-ath9k wpad-mini uboot-envtools
 
 define Target/Description
-       Build firmware images for Atheros AR71xx based boards
+       Build firmware images for Atheros AR7xxx/AR9xxx based boards.
 endef
 
 $(eval $(call BuildTarget))