[ar71xx] add initial profiles
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / Makefile
index 1572c84319fd0a1f8a2d1099b89a2dd77eb0b95a..893742600762f95d709969f8df279230fc1864a3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx
-FEATURES:=squashfs tgz broken
+BOARDNAME:=Atheros AR71xx/AR913x
+FEATURES:=squashfs tgz
 
-LINUX_VERSION:=2.6.26.3
+LINUX_VERSION:=2.6.28.7
 
 include $(INCLUDE_DIR)/target.mk
 
-#DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += hostapd-mini kmod-madwifi kmod-gpio-leds
 
 define Target/Description
-       Build firmware images for Atheros AR71xx based boards
+       Build firmware images for Atheros AR71xx/AR913x based boards
 endef
 
 $(eval $(call BuildTarget))