[ar71xx] add initial profiles
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / Makefile
index 8db27eb955dc1d52f1e2d88bc7001e0d615ab543..893742600762f95d709969f8df279230fc1864a3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx
+BOARDNAME:=Atheros AR71xx/AR913x
 FEATURES:=squashfs tgz
 
-LINUX_VERSION:=2.6.27.12
+LINUX_VERSION:=2.6.28.7
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
+DEFAULT_PACKAGES += hostapd-mini kmod-madwifi kmod-gpio-leds
 
 define Target/Description
-       Build firmware images for Atheros AR71xx based boards
+       Build firmware images for Atheros AR71xx/AR913x based boards
 endef
 
 $(eval $(call BuildTarget))