[avr32] fix u-boot build error (make[...]: avr32-linux-gcc: Command not found)
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / Makefile
index 9459c3d17a79b1e5c4a0d20992015a593bfec1d7..948c4615cf411e6f6b1753ada4683512ba50f532 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx
+BOARDNAME:=Atheros AR71xx/AR913x
 FEATURES:=squashfs tgz
 
-LINUX_VERSION:=2.6.27.7
+LINUX_VERSION:=2.6.28.7
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += \
+       kmod-gpio-leds kmod-input-core kmod-input-polldev \
+       kmod-input-gpio-buttons kmod-button-hotplug
 
 define Target/Description
-       Build firmware images for Atheros AR71xx based boards
+       Build firmware images for Atheros AR71xx/AR913x based boards.
 endef
 
 $(eval $(call BuildTarget))