[ar71xx] add AR7240 to BOARDNAME
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / Makefile
index 3f9d15f1cab3a9514cf05163b4f03fe12f7f69d3..a048b421be74c22262aa64bd4b956f848aec5d50 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx
-FEATURES:=squashfs tgz
+BOARDNAME:=Atheros AR71xx/AR7240/AR913x
+FEATURES:=squashfs jffs2 tgz
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
-LINUX_VERSION:=2.6.26.5
+LINUX_VERSION:=2.6.28.10
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += \
+       kmod-gpio-leds kmod-input-core kmod-input-polldev \
+       kmod-input-gpio-buttons kmod-button-hotplug
 
 define Target/Description
-       Build firmware images for Atheros AR71xx based boards
+       Build firmware images for Atheros AR71xx/AR913x based boards.
 endef
 
 $(eval $(call BuildTarget))