ar71xx: revert accidental kernel upgrade
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / Makefile
index c604acfabcf6b8d2d04d4f745525675d00f0fa66..b05ad6de3015aa149f6907136c19ce0d4cdcc0cc 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR71xx/AR7240/AR913x
-FEATURES:=squashfs jffs2 tgz
+FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+SUBTARGETS:=generic nand
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.32.29
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-buttons kmod-button-hotplug
+       kmod-input-gpio-buttons kmod-button-hotplug swconfig
 
 define Target/Description
        Build firmware images for Atheros AR71xx/AR913x based boards.