ar71xx: add support for the TP-Link TL-WA901ND v2 board
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / Makefile
index 849f4c2155bdea023c8277e95c240455e205a6b9..b0b096a2fe449dda8fb0543dbb97a6e4625fe3b1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,21 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx
-FEATURES:=squashfs tgz broken
+BOARDNAME:=Atheros AR71xx/AR7240/AR913x
+FEATURES:=squashfs jffs2 targz
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+SUBTARGETS:=generic nand
 
-LINUX_VERSION:=2.6.25.10
+LINUX_VERSION:=2.6.37.1
 
 include $(INCLUDE_DIR)/target.mk
 
-#DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-input-core kmod-input-polldev \
+       kmod-input-gpio-buttons kmod-button-hotplug swconfig
 
 define Target/Description
-       Build firmware images for Atheros AR71xx based boards
+       Build firmware images for Atheros AR71xx/AR913x based boards.
 endef
 
 $(eval $(call BuildTarget))