ar71xx: use the gpio_keys_polled driver instead of gpio_buttons
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / Makefile
index d5866a282f4c78a0bd7935765c8c77ddfdbbe3a4..b223c40dd8863595997ac82f6806c7d716ad9428 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,20 +8,21 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR7240/AR913x
-FEATURES:=squashfs jffs2 tgz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+BOARDNAME:=Atheros AR71xx/AR7240/AR913x/AR934x
+FEATURES:=squashfs jffs2 targz
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+SUBTARGETS:=generic nand
 
-LINUX_VERSION:=2.6.30.8
+LINUX_VERSION:=2.6.37.6
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-buttons kmod-button-hotplug
+       kmod-input-gpio-keys-polled kmod-button-hotplug swconfig
 
 define Target/Description
-       Build firmware images for Atheros AR71xx/AR913x based boards.
+       Build firmware images for Atheros AR71xx/AR913x/AR934x based boards.
 endef
 
 $(eval $(call BuildTarget))