build: unify target independent optimization options
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / Makefile
index 2b94f7c722701af1caa7a2d56e43afeb77b09765..c123598e3b83455b32db18c9b739f576369e053f 100644 (file)
@@ -8,22 +8,22 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR7240/AR913x/AR934x
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+BOARDNAME:=Atheros AR7xxx/AR9xxx
+FEATURES:=squashfs targz mips16
+CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=2.6.39.4
+LINUX_VERSION:=3.10.3
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug swconfig \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
        kmod-ath9k wpad-mini uboot-envtools
 
 define Target/Description
-       Build firmware images for Atheros AR71xx/AR913x/AR934x based boards.
+       Build firmware images for Atheros AR7xxx/AR9xxx based boards.
 endef
 
 $(eval $(call BuildTarget))