build: unify target independent optimization options
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / Makefile
index 49da9a39e501a34de67d12d4e7442e62f8004a16..c123598e3b83455b32db18c9b739f576369e053f 100644 (file)
@@ -9,16 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+FEATURES:=squashfs targz mips16
+CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.10.3
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug kmod-wdt-ath79 swconfig \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
        kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
        kmod-ath9k wpad-mini uboot-envtools