[ar71xx] add experimental support for the Linksys WRT400N board (thanks to netprince)
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / files / arch / mips / ar71xx / Makefile
index 4726120e8ded7d2ad02d833d0599c2d37908cd3e..39510988c1960b084c464094e3ef59a54a93e1d9 100644 (file)
@@ -8,8 +8,9 @@
 # under the terms of the GNU General Public License version 2 as published
 # by the Free Software Foundation.
 
-obj-y  := prom.o irq.o setup.o platform.o gpio.o ar71xx.o
+obj-y  := prom.o irq.o setup.o devices.o gpio.o ar71xx.o
 
+obj-$(CONFIG_AR71XX_MACH_AP81)         += mach-ap81.o
 obj-$(CONFIG_AR71XX_MACH_AP83)         += mach-ap83.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)     += mach-aw-nr580.o
 obj-$(CONFIG_AR71XX_MACH_GENERIC)      += mach-generic.o
@@ -22,3 +23,4 @@ obj-$(CONFIG_AR71XX_MACH_TL_WR941ND)  += mach-tl-wr941nd.o
 obj-$(CONFIG_AR71XX_MACH_UBNT)         += mach-ubnt.o
 obj-$(CONFIG_AR71XX_MACH_WNR2000)      += mach-wnr2000.o
 obj-$(CONFIG_AR71XX_MACH_WP543)                += mach-wp543.o
+obj-$(CONFIG_AR71XX_MACH_WRT400N)      += mach-wrt400n.o