ar71xx: add TP-LINK TL-WDR3320 v2 support
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index 96ff12ae74cd432c42c39376009580b4c36a2cd5..2875290e9901ee4f5772aaa6e20ba5691f1e4612 100644 (file)
@@ -5,6 +5,39 @@
 # See /LICENSE for more information.
 #
 
+define Profile/ARCHERC7
+       NAME:=TP-LINK Archer C5/C7
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev kmod-ath10k
+endef
+
+define Profile/ARCHERC7/Description
+       Package set optimized for the TP-LINK Archer C5/C7.
+endef
+$(eval $(call Profile,ARCHERC7))
+
+
+define Profile/CPE510
+       NAME:=TP-LINK CPE210/220/510/520
+       PACKAGES:=rssileds
+endef
+
+define Profile/CPE510/Description
+       Package set optimized for the TP-LINK CPE210/220/510/520.
+endef
+$(eval $(call Profile,CPE510))
+
+
+define Profile/TLMR10U
+       NAME:=TP-LINK TL-MR10U
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLMR10U/Description
+       Package set optimized for the TP-LINK TL-MR10U.
+endef
+$(eval $(call Profile,TLMR10U))
+
+
 define Profile/TLMR11U
        NAME:=TP-LINK TL-MR11U
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
@@ -15,6 +48,27 @@ define Profile/TLMR11U/Description
 endef
 $(eval $(call Profile,TLMR11U))
 
+define Profile/TLMR12U
+       NAME:=TP-LINK TL-MR12U
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR12U/Description
+       Package set optimized for the TP-LINK TL-MR12U.
+endef
+
+$(eval $(call Profile,TLMR12U))
+
+define Profile/TLMR13U
+       NAME:=TP-LINK TL-MR13U
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR13U/Description
+       Package set optimized for the TP-LINK TL-MR13U.
+endef
+$(eval $(call Profile,TLMR13U))
+
 
 define Profile/TLMR3020
        NAME:=TP-LINK TL-MR3020
@@ -27,6 +81,17 @@ endef
 $(eval $(call Profile,TLMR3020))
 
 
+define Profile/TLMR3040
+       NAME:=TP-LINK TL-MR3040
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR3040/Description
+       Package set optimized for the TP-LINK TL-MR3040.
+endef
+$(eval $(call Profile,TLMR3040))
+
+
 define Profile/TLMR3220
        NAME:=TP-LINK TL-MR3220
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
@@ -61,6 +126,30 @@ endef
 $(eval $(call Profile,TLWR703))
 
 
+define Profile/TLWR710
+       NAME:=TP-LINK TL-WR710N
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+
+define Profile/TLWR710/Description
+       Package set optimized for the TP-LINK TL-WR710N.
+endef
+$(eval $(call Profile,TLWR710))
+
+
+define Profile/TLWR720
+       NAME:=TP-LINK TL-WR720N
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+
+define Profile/TLWR720/Description
+       Package set optimized for the TP-LINK TL-WR720N.
+endef
+$(eval $(call Profile,TLWR720))
+
+
 define Profile/TLWA701
        NAME:=TP-LINK TL-WA701N/ND
        PACKAGES:=
@@ -71,6 +160,89 @@ define Profile/TLWA701/Description
 endef
 $(eval $(call Profile,TLWA701))
 
+define Profile/TLWA7210
+        NAME:=TP-LINK TL-WA7210N
+        PACKAGES:=rssileds kmod-ledtrig-netdev
+endef
+
+define Profile/TLWA7210/Description
+        Package set optimized for the TP-LINK TL-WA7210N.
+endef
+$(eval $(call Profile,TLWA7210))
+
+define Profile/TLWA730RE
+       NAME:=TP-LINK TL-WA730RE
+       PACKAGES:=
+endef
+
+define Profile/TLWA730RE/Description
+       Package set optimized for the TP-LINK TL-WA730RE.
+endef
+$(eval $(call Profile,TLWA730RE))
+
+define Profile/TLWA750
+       NAME:=TP-LINK TL-WA750RE
+       PACKAGES:=rssileds
+endef
+
+define Profile/TLWA750/Description
+       Package set optimized for the TP-LINK TL-WA750RE.
+endef
+$(eval $(call Profile,TLWA750))
+
+
+define Profile/TLWA7510
+       NAME:=TP-LINK TL-WA7510N
+       PACKAGES:=
+endef
+
+define Profile/TLWA7510/Description
+       Package set optimized for the TP-LINK TL-WA7510N.
+endef
+$(eval $(call Profile,TLWA7510))
+
+define Profile/TLWA801
+       NAME:=TP-LINK TL-WA801N/ND
+       PACKAGES:=
+endef
+
+define Profile/TLWA801/Description
+       Package set optimized for the TP-LINK TL-WA801N/ND.
+endef
+$(eval $(call Profile,TLWA801))
+
+define Profile/TLWA830
+       NAME:=TP-LINK TL-WA830RE
+       PACKAGES:=
+endef
+
+define Profile/TLWA830/Description
+       Package set optimized for the TP-LINK TL-WA830RE.
+endef
+$(eval $(call Profile,TLWA830))
+
+
+define Profile/TLWA850
+       NAME:=TP-LINK TL-WA850RE
+       PACKAGES:=rssileds
+endef
+
+define Profile/TLWA850/Description
+       Package set optimized for the TP-LINK TL-WA850RE.
+endef
+$(eval $(call Profile,TLWA850))
+
+
+define Profile/TLWA860
+       NAME:=TP-LINK TL-WA860RE
+       PACKAGES:=
+endef
+
+define Profile/TLWA860/Description
+       Package set optimized for the TP-LINK TL-WA860RE.
+endef
+$(eval $(call Profile,TLWA860))
+
 
 define Profile/TLWA901
        NAME:=TP-LINK TL-WA901N/ND
@@ -83,6 +255,50 @@ endef
 $(eval $(call Profile,TLWA901))
 
 
+define Profile/TLWDR4300
+       NAME:=TP-LINK TL-WDR3500/3600/4300/4310/MW4350R
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWDR4300/Description
+       Package set optimized for the TP-LINK TL-WDR3500/3600/4300/4310/MW4350R.
+endef
+$(eval $(call Profile,TLWDR4300))
+
+
+define Profile/TLWDR3320V2
+       NAME:=TP-LINK TL-WDR3320v2
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWDR3320V2/Description
+       Package set optimized for the TP-LINK TL-WDR3320v2.
+endef
+$(eval $(call Profile,TLWDR3320V2))
+
+
+define Profile/TLWDR4900V2
+       NAME:=TP-LINK TL-WDR4900v2
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWDR4900V2/Description
+       Package set optimized for the TP-LINK TL-WDR4900v2.
+endef
+$(eval $(call Profile,TLWDR4900V2))
+
+
+define Profile/TLWDR6500V2
+       NAME:=TP-LINK TL-WDR6500v2
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev kmod-ath10k
+endef
+
+define Profile/TLWDR6500V2/Description
+       Package set optimized for the TP-LINK TL-WDR6500v2.
+endef
+$(eval $(call Profile,TLWDR6500V2))
+
+
 define Profile/TLWR740
        NAME:=TP-LINK TL-WR740N/ND
        PACKAGES:=
@@ -138,6 +354,17 @@ endef
 $(eval $(call Profile,TLWR842))
 
 
+define Profile/TLWR843
+       NAME:=TP-LINK TL-WR843N/ND
+       PACKAGES:=
+endef
+
+define Profile/TLWR843/Description
+       Package set optimized for the TP-LINK TL-WR843N/ND.
+endef
+$(eval $(call Profile,TLWR843))
+
+
 define Profile/TLWR941
        NAME:=TP-LINK TL-WR941N/ND
        PACKAGES:=
@@ -149,6 +376,17 @@ endef
 $(eval $(call Profile,TLWR941))
 
 
+define Profile/TLWR1041
+       NAME:=TP-LINK TL-WR1041N
+       PACKAGES:=
+endef
+
+define Profile/TLWR1041/Description
+       Package set optimized for the TP-LINK TL-WR1041N/ND.
+endef
+$(eval $(call Profile,TLWR1041))
+
+
 define Profile/TLWR1043
        NAME:=TP-LINK TL-WR1043N/ND
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev