ar71xx: add kmod-ledtrig-usbdev to the relevant profiles
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index 7efb1a3766fe643e237ef1a8ee3a73d3fa9b0172..ec9f423810f9096817409da66b6154b8c59b7be8 100644 (file)
@@ -5,6 +5,39 @@
 # See /LICENSE for more information.
 #
 
+define Profile/TLMR3220V1
+       NAME:=TP-LINK TL-MR3220 v1
+       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR3220V1/Description
+       Package set optimized for the TP-LINK TL-MR3220 v1.
+endef
+
+$(eval $(call Profile,TLMR3220V1))
+
+define Profile/TLMR3420V1
+       NAME:=TP-LINK TL-MR3420 v1
+       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR3420V1/Description
+       Package set optimized for the TP-LINK TL-MR3420 v1.
+endef
+
+$(eval $(call Profile,TLMR3420V1))
+
+define Profile/TLWA901NDV1
+       NAME:=TP-LINK TL-WA901ND v1
+       PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWA901NDV1/Description
+       Package set optimized for the TP-LINK TL-WA901ND v1.
+endef
+
+$(eval $(call Profile,TLWA901NDV1))
+
 define Profile/TLWR741NDV1
        NAME:=TP-LINK TL-WR741ND v1
        PACKAGES:=kmod-ath9k wpad-mini
@@ -16,6 +49,17 @@ endef
 
 $(eval $(call Profile,TLWR741NDV1))
 
+define Profile/TLWR740NV1
+       NAME:=TP-LINK TL-WR740N v1
+       PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR740NV1/Description
+       Package set optimized for the TP-LINK TL-WR740N v1.
+endef
+
+$(eval $(call Profile,TLWR740NV1))
+
 define Profile/TLWR841NV15
        NAME:=TP-LINK TL-WR841N v1.5
        PACKAGES:=kmod-ath9k wpad-mini
@@ -49,6 +93,17 @@ endef
 
 $(eval $(call Profile,TLWR841NDV5))
 
+define Profile/TLWR841NDV7
+       NAME:=TP-LINK TL-WR841ND v7
+       PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR841NDV7/Description
+       Package set optimized for the TP-LINK TL-WR841ND v7.
+endef
+
+$(eval $(call Profile,TLWR841NDV7))
+
 define Profile/TLWR941NDV2
        NAME:=TP-LINK TL-WR941ND v2
        PACKAGES:=kmod-ath9k wpad-mini
@@ -84,7 +139,7 @@ $(eval $(call Profile,TLWR941NDV4))
 
 define Profile/TLWR1043NDV1
        NAME:=TP-LINK TL-WR1043ND v1
-       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLWR1043NDV1/Description