ar71xx: create images for the WNDR3700, which can be flashed via the factory web...
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / image / Makefile
index b61524ecdb778b93683558070938dc1157aebe9e..04629ffd54e2071e6bc2e25fe28dd61c3d3eea4b 100644 (file)
@@ -141,11 +141,7 @@ endef
 ubntxm_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1024k(kernel),6528k(rootfs),256k(cfg)ro,64k(EEPROM)ro,7552k@0x50000(firmware)
 define Image/Build/UBNTXM
        $(call PatchKernelLzma,$(2),$(3) $(ubntxm_mtdlayout))
-       mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
-               0x80060000 \
-               -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
-               -d $(KDIR)/vmlinux-$(2).bin.lzma \
-               $(KDIR)/vmlinux-$(2).uImage.bin
+       $(call MkImageLzma,$(KDIR)/vmlinux-$(2).bin.lzma,$(KDIR)/vmlinux-$(2).uImage.bin)
        dd if=$(KDIR)/vmlinux-$(2).uImage.bin of=$(KDIR)/vmlinux-$(2).uImage bs=1024k conv=sync
        -$(STAGING_DIR_HOST)/bin/mkfwimage \
                -B $(4) -v $(5).$(6).OpenWrt.$(REVISION) \
@@ -201,7 +197,7 @@ define Image/Build/TPLINK
                -B $(4) -N OpenWrt -V $(REVISION)\
                -k $(KDIR)/vmlinux-$(2).bin.gz \
                -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
-               -o $(call imgname,$(1),$(2)).uni
+               -o $(call imgname,$(1),$(2))-universal.bin
 endef
 
 define Image/Build/CyberTAN
@@ -219,6 +215,38 @@ define Image/Build/CyberTAN
                -o $(call imgname,$(1),$(2)).bin
 endef
 
+wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),6656k(rootfs),64k(art)ro,7680k@0x70000(firmware)
+define Image/Build/WNDR3700
+       $(call PatchKernelLzma,$(2),$(3) $(wndr3700_mtdlayout))
+       $(call MkImageLzma,$(KDIR)/vmlinux-$(2).bin.lzma,$(KDIR)/vmlinux-$(2).uImage)
+       mkdir $(KDIR)/wndr3700
+       mkdir $(KDIR)/wndr3700/image
+       $(STAGING_DIR_HOST)/bin/wndr3700 \
+               $(KDIR)/vmlinux-$(2).uImage \
+               $(KDIR)/wndr3700/image/uImage
+       $(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
+               $(KDIR)/wndr3700 $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp \
+               -nopad -noappend -root-owned -be
+       -rm -rf $(KDIR)/wndr3700
+       mkimage -A mips -O linux -T filesystem -C none \
+               -a 0xbf070000 -e 0xbf070000 \
+               -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -d $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp \
+               $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp2
+       $(STAGING_DIR_HOST)/bin/wndr3700 \
+               $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp2 \
+               $(KDIR)/vmlinux-$(2).uImage.squashfs
+       -rm -f $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp*
+       ( \
+               dd if=$(KDIR)/vmlinux-$(2).uImage.squashfs bs=1M conv=sync; \
+               dd if=$(KDIR)/root.$(1) bs=64k; \
+       ) > $(call imgname,$(1),$(2))-sysupgrade.bin
+       $(STAGING_DIR_HOST)/bin/mkdniimg \
+               -B WNDR3700 -v OpenWrt.$(REVISION) \
+               -i $(call imgname,$(1),$(2))-sysupgrade.bin \
+               -o $(call imgname,$(1),$(2))-factory.bin
+endef
+
 define Image/Build/Template/Compex
        $(call Image/Build/MyLoader,$(1),$(2))
 endef
@@ -323,6 +351,18 @@ define Image/Build/Template/Planex/jffs2-64k
        $(call Image/Build/Template/Planex,jffs2-64k,$(1),$(2))
 endef
 
+define Image/Build/Template/WNDR3700
+       $(call Image/Build/WNDR3700,$(1),$(2),$(3))
+endef
+
+define Image/Build/Template/WNDR3700/squashfs
+       $(call Image/Build/Template/WNDR3700,squashfs,$(1),$(2))
+endef
+
+define Image/Build/Template/WNDR3700/jffs2-64k
+       $(call Image/Build/Template/WNDR3700,jffs2-64k,$(1),$(2))
+endef
+
 define Image/Build/Profile/AP83
        $(call Image/Build/Template/AP83/$(1),ap83,board=AP83)
 endef
@@ -404,6 +444,10 @@ define Image/Build/Profile/TLWR941NDV2
        $(call Image/Build/Template/TPLINK/$(1),tl-wr941ndv2,board=TL-WR941ND,TL-WR941NDv2)
 endef
 
+define Image/Build/Profile/WNDR3700
+       $(call Image/Build/Template/WNDR3700/$(1),wndr3700,board=WNDR3700)
+endef
+
 define Image/Build/Profile/WRT400N
        $(call Image/Build/Template/WRT400N/$(1),wrt400n,board=WRT400N)
 endef
@@ -426,6 +470,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR941NDV2,$(1))
        $(call Image/Build/Profile/UBNT,$(1))
        $(call Image/Build/Profile/WP543,$(1))
+       $(call Image/Build/Profile/WNDR3700,$(1))
        $(call Image/Build/Profile/WRT400N,$(1))
        $(call Image/Build/Profile/WRT160NL,$(1))
 endef