[ar71xx] fix image generation in the Image Builder environment
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / image / Makefile
index 4c96a88bcf6b198ddf5407368c5a671eaa596cf9..197532b690e8ffb58d5251e4f3384b968a5183ff 100644 (file)
@@ -342,14 +342,14 @@ define Image/Build/CyberTAN
        rm $(KDIR)/image.tmp
 endef
 
-wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),6656k(rootfs),64k(art)ro,7680k@0x70000(firmware)
-define Image/Build/WNDR3700
-       $(call PatchKernelLzma,$(2),$(3) $(wndr3700_mtdlayout))
+define Image/Build/Netgear
+       $(call PatchKernelLzma,$(2),$(3) $($(4)))
        $(call MkImageLzma,$(KDIR)/vmlinux-$(2).bin.lzma,$(KDIR)/vmlinux-$(2).uImage)
        mkdir -p $(KDIR)/wndr3700/image
        $(STAGING_DIR_HOST)/bin/wndr3700 \
                $(KDIR)/vmlinux-$(2).uImage \
-               $(KDIR)/wndr3700/image/uImage
+               $(KDIR)/wndr3700/image/uImage \
+               $(5)
        $(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
                $(KDIR)/wndr3700 $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp \
                -nopad -noappend -root-owned -be
@@ -361,24 +361,41 @@ define Image/Build/WNDR3700
                $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp2
        $(STAGING_DIR_HOST)/bin/wndr3700 \
                $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp2 \
-               $(KDIR)/vmlinux-$(2).uImage.squashfs
+               $(KDIR)/vmlinux-$(2).uImage.squashfs \
+               $(5)
        -rm -f $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp*
        ( \
                dd if=$(KDIR)/vmlinux-$(2).uImage.squashfs bs=1024k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k; \
        ) > $(call imgname,$(1),$(2))-sysupgrade.bin
        $(STAGING_DIR_HOST)/bin/mkdniimg \
-               -B WNDR3700 -v OpenWrt.$(REVISION) \
+               -B $(6) -v OpenWrt.$(REVISION) \
                -i $(call imgname,$(1),$(2))-sysupgrade.bin \
                -o $(call imgname,$(1),$(2))-factory.img
+       $(STAGING_DIR_HOST)/bin/mkdniimg \
+               -B $(6) -v OpenWrt.$(REVISION) -r "NA" \
+               -i $(call imgname,$(1),$(2))-sysupgrade.bin \
+               -o $(call imgname,$(1),$(2))-factory-NA.img
 endef
 
-define Image/Build/ZyXEL
+define Image/Build/Netgear/initramfs
+       $(call PatchKernelLzma,$(2),$(3) $($(4)))
+       $(call MkImageLzma,$(KDIR)/vmlinux-$(2).bin.lzma,$(KDIR)/vmlinux-$(2).uImage)
+       $(STAGING_DIR_HOST)/bin/wndr3700 \
+               $(KDIR)/vmlinux-$(2).uImage \
+               $(call imgname,$(1),$(2))-uImage.bin \
+               $(5)
+endef
+
+ifdef CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh
+  define Image/Build/ZyXEL
        $(call PatchKernelLzma,$(2),$(3))
        if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 917504 ]; then \
                echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
        else if [ `stat -c%s $(KDIR)/root.$(1)` -gt 2752512 ]; then \
                echo "Warning: $(KDIR)/root.$(1) is too big"; \
+       else if [ ! -f $(BIN_DIR)/$(IMG_PREFIX)-$(2)-u-boot.bin ]; then \
+               echo "Warning: $(IMG_PREFIX)-$(2)-u-boot.bin not found"; \
        else \
                mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
                        0x80060000 \
@@ -393,16 +410,9 @@ define Image/Build/ZyXEL
                        -b $(BIN_DIR)/$(IMG_PREFIX)-$(2)-u-boot.bin \
                        -r $(call imgname,$(1),$(2))-sysupgrade.bin:0x10000 \
                        -o $(call imgname,$(1),$(2))-factory.bin; \
-       fi; fi
-endef
-
-define Image/Build/WNDR3700/initramfs
-       $(call PatchKernelLzma,$(2),$(3) $(wndr3700_mtdlayout))
-       $(call MkImageLzma,$(KDIR)/vmlinux-$(2).bin.lzma,$(KDIR)/vmlinux-$(2).uImage)
-       $(STAGING_DIR_HOST)/bin/wndr3700 \
-               $(KDIR)/vmlinux-$(2).uImage \
-               $(call imgname,$(1),$(2))-uImage.bin
-endef
+       fi; fi; fi
+  endef
+endif
 
 define Image/Build/Zcomax
        $(call PatchKernelLzma,$(2),$(3))
@@ -493,6 +503,10 @@ define Image/Build/Profile/EAP7660D
        $(call Image/Build/Template/$(fs_128k)/$(1),PB4X,eap7660d,board=EAP7660D)
 endef
 
+define Image/Build/Profile/JA76PF
+       $(call Image/Build/Template/$(fs_64k)/$(1),PB4X,ja76pf,board=JA76PF)
+endef
+
 define Image/Build/Profile/JWAP003
        $(call Image/Build/Template/$(fs_64k)/$(1),PB4X,jwap003,board=JWAP003)
 endef
@@ -568,6 +582,10 @@ define Image/Build/Profile/NBG_460N_550N_550NH
        $(call Image/Build/Template/$(fs_64k)/$(1),ZyXEL,nbg460n_550n_550nh,board=NBG460N,NBG-460N)
 endef
 
+define Image/Build/Profile/TLMR3220V1
+       $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-mr3220-v1,board=TL-MR3220,TL-MR3220v1)
+endef
+
 define Image/Build/Profile/TLMR3420V1
        $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-mr3420-v1,board=TL-MR3420,TL-MR3420v1)
 endef
@@ -576,10 +594,18 @@ define Image/Build/Profile/TLWA901NDV1
        $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wa901nd-v1,board=TL-WA901ND,TL-WA901NDv1)
 endef
 
+define Image/Build/Profile/TLWA901NDV2
+       $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wa901nd-v2,board=TL-WA901ND-v2,TL-WA901NDv2)
+endef
+
 define Image/Build/Profile/TLWR741NDV1
        $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr741nd-v1,board=TL-WR741ND,TL-WR741NDv1)
 endef
 
+define Image/Build/Profile/TLWR740NV1
+       $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr740n-v1,board=TL-WR741ND,TL-WR740Nv1)
+endef
+
 define Image/Build/Profile/TLWR841NV15
        $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr841n-v1.5,board=TL-WR841N-v1.5,TL-WR841Nv1.5)
 endef
@@ -612,8 +638,11 @@ define Image/Build/Profile/TLWR1043NDV1
        $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr1043nd-v1,board=TL-WR1043ND,TL-WR1043NDv1)
 endef
 
+wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),6656k(rootfs),64k(art)ro,7680k@0x70000(firmware)
+wndr3700v2_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),14848k(rootfs),64k(art)ro,15872k@0x70000(firmware)
 define Image/Build/Profile/WNDR3700
-       $(call Image/Build/Template/$(fs_64k)/$(1),WNDR3700,wndr3700,board=WNDR3700)
+       $(call Image/Build/Template/$(fs_64k)/$(1),Netgear,wndr3700,board=WNDR3700,wndr3700_mtdlayout,3700,WNDR3700)
+       $(call Image/Build/Template/$(fs_64k)/$(1),Netgear,wndr3700v2,board=WNDR3700v2,wndr3700v2_mtdlayout,3701,WNDR3700v2)
 endef
 
 define Image/Build/Profile/AP96
@@ -653,6 +682,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/DIR825B1,$(1))
        $(call Image/Build/Profile/EAP7660D,$(1))
        $(call Image/Build/Profile/FR54RTR,$(1))
+       $(call Image/Build/Profile/JA76PF,$(1))
        $(call Image/Build/Profile/JWAP003,$(1))
        $(call Image/Build/Profile/MZKW04NU,$(1))
        $(call Image/Build/Profile/MZKW300NH,$(1))
@@ -662,9 +692,12 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/PB92,$(1))
        $(call Image/Build/Profile/TEW632BRP,$(1))
        $(call Image/Build/Profile/TEW652BRP,$(1))
+       $(call Image/Build/Profile/TLMR3220V1,$(1))
        $(call Image/Build/Profile/TLMR3420V1,$(1))
        $(call Image/Build/Profile/TLWA901NDV1,$(1))
+       $(call Image/Build/Profile/TLWA901NDV2,$(1))
        $(call Image/Build/Profile/TLWR741NDV1,$(1))
+       $(call Image/Build/Profile/TLWR740NV1,$(1))
        $(call Image/Build/Profile/TLWR841NV15,$(1))
        $(call Image/Build/Profile/TLWR841NDV3,$(1))
        $(call Image/Build/Profile/TLWR841NDV5,$(1))