[ar71xx] tew-632brp: increase the size of rootfs partition, and build one unified...
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / image / Makefile
index 3f0cd01c7504b2387c39e05f03260eae02d98767..4a226084fb977f3ca98379d68e4be96eb45d15f2 100644 (file)
@@ -52,9 +52,8 @@ define Image/Build/AP81
                ( \
                        dd if=$(KDIR)/vmlinux-$(2).uImage bs=768k conv=sync; \
                        dd if=$(KDIR)/root.$(1) bs=3008k conv=sync; \
-               ) > $(call imgname,$(1),$(2)).bin; \
-               cp $(call imgname,$(1),$(2)).bin $(call imgname,$(1),$(2)).webui; \
-               echo -n $(4) >> $(call imgname,$(1),$(2)).webui; \
+                       echo -n $(4); \
+               ) > $(call imgname,$(1),$(2)).uni; \
        fi; fi
 endef
 
@@ -71,7 +70,7 @@ define Image/Build/UBNT
        $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).lzma
        dd if=$(KDIR)/vmlinux-$(2).lzma of=$(KDIR)/vmlinux-$(2).bin.lzma bs=64k conv=sync
        -$(STAGING_DIR_HOST)/bin/mkfwimage \
-               -B $(4) -v $(5).ar7100.OpenWrt \
+               -B $(4) -v $(5).ar7100.OpenWrt.$(REVISION) \
                -k $(KDIR)/vmlinux-$(2).bin.lzma \
                -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
                -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt-$(2)-$(1).bin
@@ -100,6 +99,17 @@ define Image/Build/Planex
        fi; fi
 endef
 
+define Image/Build/TPLINK
+       cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(2)
+       $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(2) '$(strip $(3))'
+       gzip -9 -c $(KDIR)/vmlinux-$(2) > $(KDIR)/vmlinux-$(2).bin.gzip
+       -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+               -B $(4) -N OpenWrt -V $(REVISION)\
+               -k $(KDIR)/vmlinux-$(2).bin.gzip \
+               -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+               -o $(BIN_DIR)/openwrt-$(BOARD)-$(2)-$(1).bin
+endef
+
 define Image/Build/Template/Compex
        $(call Image/Build/MyLoader,$(1),$(2))
 endef
@@ -116,6 +126,14 @@ define Image/Build/Template/AP81/squashfs
        $(call Image/Build/Template/AP81,squashfs,$(1),$(2),$(3))
 endef
 
+define Image/Build/Template/TPLINK
+       $(call Image/Build/TPLINK,$(1),$(2),$(3),$(4))
+endef
+
+define Image/Build/Template/TPLINK/squashfs
+       $(call Image/Build/Template/TPLINK,squashfs,$(1),$(2),$(3))
+endef
+
 define Image/Build/Template/UBNT
        $(call Image/Build/UBNT,$(1),$(2),$(3),$(4),$(5))
 endef
@@ -156,20 +174,34 @@ define Image/Build/Profile/MZKW04NU
        $(call Image/Build/Template/Planex/$(1),mzk-w04nu,board=MZK-W04NU)
 endef
 
-define Image/Build/squashfs
-       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+define Image/Build/Profile/TLWR941NDV2
+       $(call Image/Build/Template/TPLINK/$(1),tl-wr941ndv2,board=TL-WR941ND,TL-WR941NDv2)
 endef
 
-define Image/Build
-       $(call Image/Build/$(1))
-       dd if=$(KDIR)/root.$(1) of=$(IMGNAME)-root.$(1) bs=128k conv=sync
-
+define Image/Build/Profile/Default
        $(call Image/Build/Profile/DIR615C1,$(1))
        $(call Image/Build/Profile/MZKW04NU,$(1))
        $(call Image/Build/Profile/TEW632BRP,$(1))
        $(call Image/Build/Profile/TEW652BRP,$(1))
+       $(call Image/Build/Profile/TLWR941NDV2,$(1))
+       $(call Image/Build/Profile/UBNTRS,$(1))
+       $(call Image/Build/Profile/WP543,$(1))
+endef
+
+define Image/Build/Profile/Madwifi
        $(call Image/Build/Profile/UBNTRS,$(1))
        $(call Image/Build/Profile/WP543,$(1))
 endef
 
+define Image/Build/squashfs
+       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+       $(call Image/Build/$(1))
+       dd if=$(KDIR)/root.$(1) of=$(IMGNAME)-root.$(1) bs=128k conv=sync
+
+       $(call Image/Build/Profile/$(PROFILE),$(1))
+endef
+
 $(eval $(call BuildImage))