[ar71xx] use MyLoader partition parser on the WP543 board
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / image / Makefile
index 4d86889a5e25b74b39e1960824c072c1f0fef15e..4baa78995e82475e5ec47361d336c03fe2cec0ac 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -7,12 +7,49 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+IMGNAME:=$(BIN_DIR)/openwrt-$(BOARD)
+
+define imgname
+$(IMGNAME)-$(2)-$(patsubst jffs2-%,jffs2,$(1))
+endef
+
+VMLINUX:=$(IMGNAME)-vmlinux
+ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+       VMLINUX:=$(IMGNAME)-vmlinux-initramfs
+endif
+
 define Image/BuildKernel
-       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+       cp $(KDIR)/vmlinux.elf $(VMLINUX).elf
+       cp $(KDIR)/vmlinux $(VMLINUX).bin
        gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
        $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
-       dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma bs=65536 conv=sync
-       dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.gz bs=65536 conv=sync
+       dd if=$(KDIR)/vmlinux.bin.l7 of=$(VMLINUX).lzma bs=65536 conv=sync
+       dd if=$(KDIR)/vmlinux.bin.gz of=$(VMLINUX).gz bs=65536 conv=sync
+       $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux -lc1 -lp2 -pb2 $(KDIR)/vmlinux.lzma
+       mkimage -A mips -O linux -T kernel -a 0x80060000 -C gzip -e \
+               0x80060000 \
+               -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -d $(KDIR)/vmlinux.bin.gz $(IMGNAME)-uImage.gz
+
+endef
+
+define Image/Build/MyLoader
+       -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) \
+               -p0x30000:0xc0000:ahl:0x80060000:kernel:$(KDIR)/vmlinux.lzma  \
+               -p0xf0000:0:::rootfs:$(KDIR)/root.$(1) \
+               $(call imgname,$(1),$(2)).img
+endef
+
+define Image/Build/Template/Compex
+       $(call Image/Build/MyLoader,$(1),$(2))
+endef
+
+define Image/Build/Template/Compex/squashfs
+       $(call Image/Build/Template/Compex,squashfs,$(1))
+endef
+
+define Image/Build/Profile/WP543
+       $(call Image/Build/Template/Compex/$(1),wp543)
 endef
 
 define Image/Build/squashfs
@@ -21,7 +58,9 @@ endef
 
 define Image/Build
        $(call Image/Build/$(1))
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+       dd if=$(KDIR)/root.$(1) of=$(IMGNAME)-root.$(1) bs=128k conv=sync
+
+       $(call Image/Build/Profile/WP543,$(1))
 endef