ar71xx: image: add mtdpartsize macro
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / image / Makefile
index 60990b284d07f361796ec5b5110e319c99c8c09c..8ac70448d5b86b0a5d0b5780659a872015c3b496 100644 (file)
@@ -31,6 +31,10 @@ define mkcmdline
 $(if $(1),board=$(1) )$(if $(2),console=$(2)$(COMMA)$(3))
 endef
 
+define mtdpartsize
+$(shell echo $$((`echo '$(2)' | sed -e 's/.*[:$(COMMA)]\([0-9]*\)k[@]*[0-9a-zx]*($(1)).*/\1/'` * 1024)))
+endef
+
 SINGLE_PROFILES:=
 
 define SingleProfile