ar71xx: Add support for WZR-HP-G301NH
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / image / Makefile
index 510595673a152ee944c04e1a36336f3b16a2bfab..e7d2f0efa202239fe881c8b26258a78bcbce26ad 100644 (file)
@@ -118,7 +118,7 @@ define Image/Build/DIR825B1
        fi; fi
 endef
 
-define Image/Build/WZRHPG300NH
+define Image/Build/WZRHPG30XNH
        $(call PatchKernelLzma,$(2),$(3))
        if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 1048576 ]; then \
                echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
@@ -246,6 +246,29 @@ define Image/Build/PB4X
                $(call imgname,$(1),$(2))-sysupgrade.bin
 endef
 
+define Image/Build/DB120
+       $(call PatchKernelLzma,$(2),$(3))
+       if [ `stat -c%s $(KDIR)/vmlinux-$(2).bin.lzma` -gt 1441792 ]; then \
+               echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
+       elif [ `stat -c%s $(KDIR)/root.$(1)` -gt 6488064 ]; then \
+               echo "Warning: $(KDIR)/root.$(1) is too big"; \
+       else \
+               mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
+                       0x80060000 \
+                       -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+                       -d $(KDIR)/vmlinux-$(2).bin.lzma \
+                       $(KDIR)/vmlinux-$(2).uImage; \
+               dd if=$(KDIR)/vmlinux-$(2).uImage \
+                       of=$(call imgname,kernel,$(2)).bin bs=64k conv=sync; \
+               dd if=$(KDIR)/root.$(1) \
+                       of=$(call imgname,$(1),$(2)-rootfs).bin bs=128k conv=sync; \
+               ( \
+                       dd if=$(KDIR)/root.$(1); \
+                       dd if=$(KDIR)/vmlinux-$(2).uImage bs=1408k conv=sync; \
+               ) > $(call imgname,$(1),$(2))-sysupgrade.bin; \
+       fi
+endef
+
 define Image/Build/MyLoader
        -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(3) \
                -p0x030000:0xe0000:al:0x80060000:kernel:$(KDIR)/vmlinux.bin.lzma \
@@ -394,6 +417,8 @@ ifdef CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh
                echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
        else if [ `stat -c%s $(KDIR)/root.$(1)` -gt 2752512 ]; then \
                echo "Warning: $(KDIR)/root.$(1) is too big"; \
+       else if [ ! -f $(BIN_DIR)/$(IMG_PREFIX)-$(2)-u-boot.bin ]; then \
+               echo "Warning: $(IMG_PREFIX)-$(2)-u-boot.bin not found"; \
        else \
                mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
                        0x80060000 \
@@ -408,7 +433,7 @@ ifdef CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh
                        -b $(BIN_DIR)/$(IMG_PREFIX)-$(2)-u-boot.bin \
                        -r $(call imgname,$(1),$(2))-sysupgrade.bin:0x10000 \
                        -o $(call imgname,$(1),$(2))-factory.bin; \
-       fi; fi
+       fi; fi; fi
   endef
 endif
 
@@ -474,6 +499,10 @@ define Image/Build/Profile/AP83
        $(call Image/Build/Template/$(fs_64k)/$(1),AP83,ap83,board=AP83)
 endef
 
+define Image/Build/Profile/DB120
+       $(call Image/Build/Template/$(fs_64k)/$(1),DB120,db120,board=DB120)
+endef
+
 define Image/Build/Profile/PB42
        $(call Image/Build/Template/$(fs_64k)/$(1),PB4X,pb42,board=PB42)
 endef
@@ -592,6 +621,10 @@ define Image/Build/Profile/TLWA901NDV1
        $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wa901nd-v1,board=TL-WA901ND,TL-WA901NDv1)
 endef
 
+define Image/Build/Profile/TLWA901NDV2
+       $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wa901nd-v2,board=TL-WA901ND-v2,TL-WA901NDv2)
+endef
+
 define Image/Build/Profile/TLWR741NDV1
        $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr741nd-v1,board=TL-WR741ND,TL-WR741NDv1)
 endef
@@ -633,8 +666,10 @@ define Image/Build/Profile/TLWR1043NDV1
 endef
 
 wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),6656k(rootfs),64k(art)ro,7680k@0x70000(firmware)
+wndr3700v2_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),14848k(rootfs),64k(art)ro,15872k@0x70000(firmware)
 define Image/Build/Profile/WNDR3700
        $(call Image/Build/Template/$(fs_64k)/$(1),Netgear,wndr3700,board=WNDR3700,wndr3700_mtdlayout,3700,WNDR3700)
+       $(call Image/Build/Template/$(fs_64k)/$(1),Netgear,wndr3700v2,board=WNDR3700v2,wndr3700v2_mtdlayout,3701,WNDR3700v2)
 endef
 
 define Image/Build/Profile/AP96
@@ -653,8 +688,9 @@ define Image/Build/Profile/WRT160NL
        $(call Image/Build/Template/$(fs_64k)/$(1),CyberTAN,wrt160nl,board=WRT160NL,1.00.01)
 endef
 
-define Image/Build/Profile/WZRHPG300NH
-       $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG300NH,wzr-hp-g300nh,board=WZR-HP-G300NH)
+define Image/Build/Profile/WZRHPG30XNH
+       $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-g300nh,board=WZR-HP-G300NH)
+       $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-g301nh,board=WZR-HP-G301NH)
 endef
 
 define Image/Build/Profile/ZCN1523H28
@@ -669,6 +705,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/AP81,$(1))
        $(call Image/Build/Profile/AP83,$(1))
        $(call Image/Build/Profile/A02RBW300N,$(1))
+       $(call Image/Build/Profile/DB120,$(1))
        $(call Image/Build/Profile/DIR600A1,$(1))
        $(call Image/Build/Profile/DIR615C1,$(1))
        $(call Image/Build/Profile/DIR825B1,$(1))
@@ -687,6 +724,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLMR3220V1,$(1))
        $(call Image/Build/Profile/TLMR3420V1,$(1))
        $(call Image/Build/Profile/TLWA901NDV1,$(1))
+       $(call Image/Build/Profile/TLWA901NDV2,$(1))
        $(call Image/Build/Profile/TLWR741NDV1,$(1))
        $(call Image/Build/Profile/TLWR740NV1,$(1))
        $(call Image/Build/Profile/TLWR841NV15,$(1))
@@ -703,7 +741,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/AP96,$(1))
        $(call Image/Build/Profile/WRT400N,$(1))
        $(call Image/Build/Profile/WRT160NL,$(1))
-       $(call Image/Build/Profile/WZRHPG300NH,$(1))
+       $(call Image/Build/Profile/WZRHPG30XNH,$(1))
        $(call Image/Build/Profile/ZCN1523H28,$(1))
        $(call Image/Build/Profile/ZCN1523H516,$(1))
 endef