[8.09] kernel: refresh patches
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / patches / 200-rb4xx_nand_driver.patch
index d9f6716641dfda635cc5fb55e45c02ea40586ea5..a0d55d666e0f7c510f8cc73b9b02afb29ba5e341 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/mtd/nand/Kconfig
 +++ b/drivers/mtd/nand/Kconfig
-@@ -330,4 +330,8 @@
-         Enabling this option will enable you to use this to control
-         external NAND devices.
+@@ -386,4 +386,8 @@ config MTD_NAND_FSL_UPM
+         Enables support for NAND Flash chips wired onto Freescale PowerPC
+         processor localbus with User-Programmable Machine support.
  
 +config MTD_NAND_RB4XX
 +      tristate "NAND flash driver for RouterBoard 4xx series"
@@ -11,9 +11,9 @@
  endif # MTD_NAND
 --- a/drivers/mtd/nand/Makefile
 +++ b/drivers/mtd/nand/Makefile
-@@ -28,6 +28,7 @@
- obj-$(CONFIG_MTD_NAND_CM_X270)                += cmx270_nand.o
+@@ -29,6 +29,7 @@ obj-$(CONFIG_MTD_NAND_CM_X270)               += cmx27
  obj-$(CONFIG_MTD_NAND_BASLER_EXCITE)  += excite_nandflash.o
+ obj-$(CONFIG_MTD_NAND_PXA3xx)         += pxa3xx_nand.o
  obj-$(CONFIG_MTD_NAND_PLATFORM)               += plat_nand.o
 +obj-$(CONFIG_MTD_NAND_RB4XX)          += rb4xx_nand.o
  obj-$(CONFIG_MTD_ALAUDA)              += alauda.o