Changed partitioning not to use at91part.c as opposed to using
[openwrt/svn-archive/archive.git] / target / linux / at91-2.6 / image / Makefile
index e2ace4251b8ad0b491e5f1897a61d7637b3e4862..73a281b8085cd5c32377854c1822289314dbc4d1 100644 (file)
@@ -35,8 +35,8 @@ define Image/BuildKernel
 endef
 
 define Image/Build
 endef
 
 define Image/Build
-       dd if=$(KDIR)/uImage of=$(KDIR)/uImage.block bs=1056k count=1 conv=sync
-       dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.block bs=2112k count=1 conv=sync
+       dd if=$(KDIR)/uImage of=$(KDIR)/uImage.block bs=8448 conv=sync
+       dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.block bs=8448 conv=sync
        cat $(KDIR)/uImage.block $(KDIR)/root.block > $(KDIR)/knlroot.bin
        $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/romboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
        cp $(KDIR)/rbptest.bin $(BIN_DIR)
        cat $(KDIR)/uImage.block $(KDIR)/root.block > $(KDIR)/knlroot.bin
        $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/romboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
        cp $(KDIR)/rbptest.bin $(BIN_DIR)