at91: bump to v3.18
[openwrt/svn-archive/archive.git] / target / linux / at91 / Makefile
index 17e6563590c3a31388b4a677ddf87c56e132ba45..040df33300285b359c496c5e550f6f6fd26cd800 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,15 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
-FEATURES:=squashfs usb
+FEATURES:=squashfs targz ext2 usb
+SUBTARGETS:=legacy sama5d3
 
-LINUX_VERSION:=2.6.25.20
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
-
-define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
-endef
+DEFAULT_PACKAGES += kmod-usb-ohci
 
 $(eval $(call BuildTarget))