kernel: update kernel version to 2.6.34.5
[openwrt/svn-archive/archive.git] / target / linux / at91 / Makefile
index dfa3bfbb65417605c60e9ca3958c0ffe36493fe4..074a68f9e5cb4c46ce6d1acf7fb761117088bd2f 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
-BOARDNAME:=AT91
-FEATURES:=squashfs usb
+BOARDNAME:=Atmel AT91
+FEATURES:=squashfs jffs2 targz
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
 
-#LINUX_VERSION:=2.6.21.5
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.34.5
+DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES+= kmod-usb-ohci
 KERNELNAME:="uImage"
 
 define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
+       Build firmware images for Acmesystems NetusG20 board
 endef
 
 $(eval $(call BuildTarget))