rpcd: iwinfo plugin fixes
[openwrt/svn-archive/archive.git] / target / linux / at91 / Makefile
index f8ca6f6be37d05b6021a28b6050b6d4d4e6011cb..372bf177e4d3b4766263b18112fabbedbaad0ff2 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,20 +8,15 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
-BOARDNAME:=AT91
-FEATURES:=squashfs usb
-
-#LINUX_VERSION:=2.6.21.5
-LINUX_VERSION:=2.6.22.4
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
+BOARDNAME:=Atmel AT91
+FEATURES:=squashfs targz ext2 usb usbgadget ubifs
+SUBTARGETS:=legacy sama5d3
 
-define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
-endef
+KERNEL_PATCHVER:=4.4
 
-include $(INCLUDE_DIR)/kernel-build.mk
+include $(INCLUDE_DIR)/target.mk
 
-#include the profiles
--include profiles/*.mk
+DEFAULT_PACKAGES += kmod-usb-ohci kmod-at91-udc kmod-usb-eth-gadget
 
-KERNELNAME:="uImage"
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))