[at91] Add support for FOXGM carrier board
[openwrt/svn-archive/archive.git] / target / linux / at91 / Makefile
index e616467a5f92a4654d03ac97e6f4aa434f996fcc..446de340555899dd6fbcf8402b5376e50a78a768 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=at91
 BOARDNAME:=Atmel AT91
-FEATURES:=squashfs usb
+FEATURES:=squashfs jffs2 targz
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
 
-LINUX_VERSION:=2.6.25.17
+LINUX_VERSION:=2.6.34.7
+DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES+= kmod-usb-ohci
 KERNELNAME:="uImage"
 
 define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
+       Build firmware images for Acmesystems NetusG20 board
 endef
 
 $(eval $(call BuildTarget))