at91: add 3.14 support
[openwrt/svn-archive/archive.git] / target / linux / at91 / Makefile
index 9808255bcec5094224e91ec014d3a9f45d1b8df6..47fc2f67df23d88f83f3aa21097b1a27d1a205d1 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,16 +10,13 @@ ARCH:=arm
 BOARD:=at91
 MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
-SUBTARGETS:=netus tqma9263
+FEATURES:=squashfs targz ext2 usb
+SUBTARGETS:=legacy
 
-LINUX_VERSION:=2.6.38
-DEVICE_TYPE=
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES+= kmod-usb-ohci
-KERNELNAME:="uImage"
+DEFAULT_PACKAGES += kmod-usb-ohci
 
 $(eval $(call BuildTarget))