[at91] Update to 2.6.38
[openwrt/svn-archive/archive.git] / target / linux / at91 / Makefile
index 2f86b311d0ceb627163615e11abc4e172c9afef3..9808255bcec5094224e91ec014d3a9f45d1b8df6 100644 (file)
@@ -8,19 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
-BOARDNAME:=NetusG20
-FEATURES:=squashfs jffs2 tgz
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
+BOARDNAME:=Atmel AT91
+FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
+SUBTARGETS:=netus tqma9263
 
-LINUX_VERSION:=2.6.34
+LINUX_VERSION:=2.6.38
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES+= kmod-usb-ohci
 KERNELNAME:="uImage"
 
-define Target/Description
-       Build firmware images for Acmesystems NetusG20 board
-endef
-
 $(eval $(call BuildTarget))