[at91] move Netus G20 into a subtarget and rework toplevel config and makefile
[openwrt/svn-archive/archive.git] / target / linux / at91 / Makefile
index 17e6563590c3a31388b4a677ddf87c56e132ba45..d06bb842e38ea359950794af95533e220f6529f1 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
-FEATURES:=squashfs usb
+FEATURES:=squashfs jffs2 targz
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
+SUBTARGETS:=netus tqma9263
 
-LINUX_VERSION:=2.6.25.20
+LINUX_VERSION:=2.6.35.9
+DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES+= kmod-usb-ohci
 KERNELNAME:="uImage"
 
-define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
-endef
-
 $(eval $(call BuildTarget))