Update 2.6.38 to 2.6.38.2
[openwrt/svn-archive/archive.git] / target / linux / at91 / Makefile
index 70a60826237a78a9f88cd982df4ed9f974ef96cc..f285c2c16d2ab3df388573f1c672df98a1f344bb 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
-FEATURES:=squashfs usb broken
+FEATURES:=squashfs jffs2 targz
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+SUBTARGETS:=netus tqma9263
 
-LINUX_VERSION:=2.6.25.20
+LINUX_VERSION:=2.6.38.2
+DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES+= kmod-usb-ohci
 KERNELNAME:="uImage"
 
-define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
-endef
-
 $(eval $(call BuildTarget))