Update 2.6.38 to 2.6.38.2
[openwrt/svn-archive/archive.git] / target / linux / at91 / Makefile
index d2308f376c1a532dd3bd272fcf58a8dca5987474..f285c2c16d2ab3df388573f1c672df98a1f344bb 100644 (file)
@@ -11,9 +11,10 @@ BOARD:=at91
 MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
 FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+SUBTARGETS:=netus tqma9263
 
-LINUX_VERSION:=2.6.35.8
+LINUX_VERSION:=2.6.38.2
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
@@ -21,8 +22,4 @@ include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+= kmod-usb-ohci
 KERNELNAME:="uImage"
 
-define Target/Description
-       Build firmware images for Acmesystems NetusG20 board
-endef
-
 $(eval $(call BuildTarget))