make the image filenames a bit shorter
[openwrt/svn-archive/archive.git] / target / linux / at91 / image / Makefile
index 7e855f06ef2f609188de771373314660820450d5..c0239ea050c64f0986c9daf4ed5f702c2befd734 100644 (file)
@@ -30,14 +30,14 @@ define Image/Prepare
 endef
 
 define Image/BuildKernel
-       cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+       cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
 endef
 
 define Image/Build
        dd if=$(KDIR)/uImage of=$(KDIR)/uImage.block bs=8448 conv=sync
        dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.block bs=8448 conv=sync
        cat $(KDIR)/uImage.block $(KDIR)/root.block > $(KDIR)/knlroot.bin
-       $(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/dfboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
+       $(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD).trx -f $(KDIR)/dfboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
        cp $(KDIR)/dfbptest.bin $(BIN_DIR)
        $(call Image/Build/$(1),$(1))
 endef