atheros: remove bogus wlan device mask checks
[openwrt/svn-archive/archive.git] / target / linux / atheros / Makefile
index 6cab959b0d7e1752b2506d56deeada840ae8aceb..dea803246be12b8eef893d197ec02e65aea18b23 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=atheros
-BOARDNAME:=Atheros
+BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.23.16
+LINUX_VERSION:=2.6.37.6
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += wpad-mini kmod-madwifi gpioctl swconfig
 
 define Target/Description
        Build firmware images for Atheros SoC boards