Use mkfwimage from athero.openwrt.net with modification for XS2 devices. Add back...
[openwrt/svn-archive/archive.git] / target / linux / atheros / image / Makefile
index 3806d92e9296661ac2a4cb75424fcd1759069cde..17b18deeed33fd0c5d47017b1a910414b675dd2c 100644 (file)
@@ -23,25 +23,15 @@ define Image/Build
        $(call Image/Build/$(1))
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
 
-       echo -en "kernel\t\t0x01\t0xBE030000\t0x" > $(BIN_DIR)/ls5-parts
-       echo -en "$(shell printf "%08X\n" $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c))" >> $(BIN_DIR)/ls5-parts
-       echo -e "\t0x80041000\t0x80041000\t$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma" >> $(BIN_DIR)/ls5-parts 
-       echo -en "rootfs\t\t0x02\t0x" >> $(BIN_DIR)/ls5-parts
-       echo -en "$(shell printf "%08X\n" $(shell expr $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c) + 3187867648 ) )" >> $(BIN_DIR)/ls5-parts
-       echo -en "\t0x$(shell printf "%08X\n" $(shell expr 3735552 - $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c) ) )" >> $(BIN_DIR)/ls5-parts
-       echo -e "\t0x00000000\t0x00000000\t$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)" >> $(BIN_DIR)/ls5-parts
-       
-       echo -en "kernel\t\t0x01\t0xBFC30000\t0x" > $(BIN_DIR)/ls2-parts
-       echo -en "$(shell printf "%08X\n" $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c))" >> $(BIN_DIR)/ls2-parts
-       echo -e "\t0x80041000\t0x80041000\t$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma" >> $(BIN_DIR)/ls2-parts
-       echo -en "rootfs\t\t0x02\t0x" >> $(BIN_DIR)/ls2-parts
-       echo -en "$(shell printf "%08X\n" $(shell expr $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c) + 3217227776 ) )" >> $(BIN_DIR)/ls2-parts
-       echo -en "\t0x$(shell printf "%08X\n" $(shell expr 3866624 - $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c) ) )" >> $(BIN_DIR)/ls2-parts
-       echo -e "\t0x00000000\t0x00000000\t$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)" >> $(BIN_DIR)/ls2-parts
-
-       $(STAGING_DIR_HOST)/bin/mkfwimage -i $(BIN_DIR)/ls2-parts -v XS2.ar2316.OpenWRT -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt-$(1).bin
-       $(STAGING_DIR_HOST)/bin/mkfwimage -i $(BIN_DIR)/ls5-parts -v XS5.ar2313.OpenWRT -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt-$(1).bin
-       rm $(BIN_DIR)/ls2-parts $(BIN_DIR)/ls5-parts
+       $(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+               -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+               -v XS2.ar2316.OpenWRT \
+               -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt2-$(1).bin
+       $(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+               -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+               -v XS5.ar2313.OpenWRT \
+               -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin \
+               -s 0xBE030000
 endef
 
 $(eval $(call BuildImage))