add gpio support to atheros, fixes #1861, thanks Othello
[openwrt/svn-archive/archive.git] / target / linux / atheros / patches-2.6.23 / 100-board.patch
index f1aa655f6961650c8536999093a81863e1a98f98..28509a3d0c6959236fc5da4d823dbcba32f970d7 100644 (file)
@@ -1,7 +1,7 @@
 diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig
 --- linux.old/arch/mips/Kconfig        2007-02-02 23:55:52.912446784 +0100
 +++ linux.dev/arch/mips/Kconfig        2007-02-03 21:50:25.262027104 +0100
-@@ -45,6 +45,15 @@
+@@ -44,6 +44,16 @@
          note that a kernel built with this option selected will not be
          able to run on normal units.
  
@@ -13,18 +13,19 @@ diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig
 +      select SYS_HAS_CPU_MIPS32_R1
 +      select SYS_SUPPORTS_BIG_ENDIAN
 +      select SYS_SUPPORTS_32BIT_KERNEL
++      select GENERIC_GPIO
 +
  config MIPS_COBALT
        bool "Cobalt Server"
        select DMA_NONCOHERENT
-@@ -658,6 +668,7 @@
+@@ -597,6 +607,7 @@
  
  endchoice
  
 +source "arch/mips/atheros/Kconfig"
  source "arch/mips/au1000/Kconfig"
- source "arch/mips/ddb5xxx/Kconfig"
- source "arch/mips/gt64120/ev64120/Kconfig"
+ source "arch/mips/jazz/Kconfig"
+ source "arch/mips/pmc-sierra/Kconfig"
 diff -urN linux.old/arch/mips/Makefile linux.dev/arch/mips/Makefile
 --- linux.old/arch/mips/Makefile       2007-02-02 23:55:52.913446632 +0100
 +++ linux.dev/arch/mips/Makefile       2007-02-03 17:40:29.193776000 +0100