atheros[ar2315-spiflash]: print detected flash size
[openwrt/svn-archive/archive.git] / target / linux / atheros / patches-3.10 / 101-early-printk-support.patch
index 7b0b2ec4decddf33b3682526b623c2f3a95de826..3daa0117f7435b5c479f49bcabf8a3997e577409 100644 (file)
@@ -1,6 +1,6 @@
 --- /dev/null
 +++ b/arch/mips/ar231x/early_printk.c
-@@ -0,0 +1,44 @@
+@@ -0,0 +1,46 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 + * License.  See the file "COPYING" in the main directory of this archive
 +                      base = (void __iomem *)(KSEG1ADDR(AR531X_UART0));
 +      }
 +
-+      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
++              ;
 +      prom_uart_wr(base, UART_TX, ch);
-+      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
++              ;
 +}
 +
 --- a/arch/mips/ar231x/Makefile
@@ -58,7 +60,7 @@
  obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -145,6 +145,7 @@ config ATHEROS_AR231X
+@@ -148,6 +148,7 @@ config ATHEROS_AR231X
        select SYS_SUPPORTS_BIG_ENDIAN
        select SYS_SUPPORTS_32BIT_KERNEL
        select ARCH_REQUIRE_GPIOLIB