upgrade to 2.6.19.1, fix Gateway 7001 patch and enable image generation for ixp4xx
[openwrt/svn-archive/archive.git] / target / linux / au1000-2.6 / Makefile
index 258990f8b76eb9fa4a0a2d54b89e84ef1f16e15c..4b20032f95124e123621419933ff8ce19e6b5fd0 100644 (file)
@@ -16,9 +16,9 @@ define Target/Description
        (e.g. 4G-Systems Mesh/Access Cube ...)
 endef
 
-LINUX_VERSION:=2.6.17
+LINUX_VERSION:=2.6.19.1
 LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
@@ -28,5 +28,23 @@ define Kernel/BuildImage
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
+define Profile/Atheros
+  NAME:=Atheros WiFi (default)
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
+define Profile/Intel
+  NAME:=Intel IPW2200 WiFi
+  PACKAGES:=kmod-net-ipw2200
+endef
+$(eval $(call Profile,Intel))
+
+define Profile/Broadcom
+  NAME:=Broadcom BCM43xx WiFi
+  PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
 $(eval $(call BuildKernel))