on the au1000 usb could never work as the power switch was never enabled :P
[openwrt/svn-archive/archive.git] / target / linux / au1000-2.6 / Makefile
index 5d2711cb30b1f447aff6ccc18f94db9b9ab70e24..bf6b5bd287a6960d64daa8e3774dd613448fa27a 100644 (file)
@@ -6,22 +6,29 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+ARCH:=mipsel
+BOARD:=au1000
+BOARDNAME:=AMD Alchemy AU1x00
+FEATURES:=jffs2 usb pci
 
-include ./config
-include $(INCLUDE_DIR)/kernel.mk
-include $(INCLUDE_DIR)/kernel-build.mk
+LINUX_VERSION:=2.6.22.1
+
+define Target/Description
+       Build firmware for AMD Alchemy 1500 boards
+       (e.g. 4G-Systems Mesh/Access Cube ...)
+endef
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += yamonenv
 
-$(LINUX_BUILD_DIR)/zImage.flash.srec: $(LINUX_DIR)/vmlinux
+define Kernel/BuildImage
+       $(call Kernel/BuildImage/Default)
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
+endef
+
+# include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))
 
-compile: $(LINUX_BUILD_DIR)/zImage.flash.srec