kernel: update linux 3.2 to 3.2.5
[openwrt/svn-archive/archive.git] / target / linux / au1000 / Makefile
index f7dcb03ed6a2586fca19af9c6f058ea8bcf7f7af..1ce821bb1a7b79d8b4afaea33db39ec73f1e90f2 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=au1000
-BOARDNAME:=AMD Alchemy AU1x00
+BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
+SUBTARGETS=au1500 au1550
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=3.2.5
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += yamonenv
+DEFAULT_PACKAGES += wpad-mini yamonenv
 
 define Target/Description
-       Build firmware for AMD Alchemy 1500 boards
-       (e.g. 4G-Systems Mesh/Access Cube ...)
+       Build firmware for RMI/AMD Alchemy 1500,1550 boards
+       (e.g. 4G-Systems Mesh/Access Cube, DBAu1550 ...)
 endef
 
 define Kernel/BuildImage
@@ -27,8 +29,4 @@ define Kernel/BuildImage
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
-