[kernel] switch to 2.6.30.3
[openwrt/svn-archive/archive.git] / target / linux / au1000 / Makefile
index 648a3ae081ffea8ddd1dc20e52dcf94ef3145aa5..499baf4c756dacb76b42618d94ca9b3fc5b2f392 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,15 +10,16 @@ ARCH:=mipsel
 BOARD:=au1000
 BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
+SUBTARGETS=au1500 au1550
 
-LINUX_VERSION:=2.6.25
+LINUX_VERSION:=2.6.30.3
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += yamonenv
+DEFAULT_PACKAGES += hostapd-mini yamonenv
 
 define Target/Description
-       Build firmware for AMD Alchemy 1500 boards
-       (e.g. 4G-Systems Mesh/Access Cube ...)
+       Build firmware for RMI/AMD Alchemy 1500,1550 boards
+       (e.g. 4G-Systems Mesh/Access Cube, DBAu1550 ...)
 endef
 
 define Kernel/BuildImage
@@ -28,4 +29,3 @@ define Kernel/BuildImage
 endef
 
 $(eval $(call BuildTarget))
-