[au1000] switch to 2.6.30.1
[openwrt/svn-archive/archive.git] / target / linux / au1000 / Makefile
index 1cb9de70a13d3d3e34de797ca4b7d2ee3ef61028..812f9da6bd2c81794f6550ef9d1e0fb05a7b6791 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,15 +10,16 @@ ARCH:=mipsel
 BOARD:=au1000
 BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
+SUBTARGETS=au1500 au1550
 
-LINUX_VERSION:=2.6.25.6
+LINUX_VERSION:=2.6.30.1
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += yamonenv
+DEFAULT_PACKAGES += hostapd-mini yamonenv
 
 define Target/Description
-       Build firmware for AMD Alchemy 1500 boards
-       (e.g. 4G-Systems Mesh/Access Cube ...)
+       Build firmware for RMI/AMD Alchemy 1500,1550 boards
+       (e.g. 4G-Systems Mesh/Access Cube, DBAu1550 ...)
 endef
 
 define Kernel/BuildImage
@@ -28,4 +29,3 @@ define Kernel/BuildImage
 endef
 
 $(eval $(call BuildTarget))
-