[au1000] switch to 2.6.32, resync kernel config, enable gpio sysfs support
[openwrt/svn-archive/archive.git] / target / linux / au1000 / Makefile
index 98be0f2b9ddb970259f38890def46e65e3333064..9a171cfe15b978ab8590622309344abad284c271 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=au1000
-BOARDNAME:=AMD Alchemy AU1x00
+BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
+SUBTARGETS=au1500 au1550
 
-LINUX_VERSION:=2.6.23.1
+LINUX_VERSION:=2.6.32.8
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += yamonenv
+DEFAULT_PACKAGES += wpad-mini yamonenv
 
 define Target/Description
-       Build firmware for AMD Alchemy 1500 boards
-       (e.g. 4G-Systems Mesh/Access Cube ...)
+       Build firmware for RMI/AMD Alchemy 1500,1550 boards
+       (e.g. 4G-Systems Mesh/Access Cube, DBAu1550 ...)
 endef
 
 define Kernel/BuildImage
@@ -28,4 +29,3 @@ define Kernel/BuildImage
 endef
 
 $(eval $(call BuildTarget))
-