bcm53xx: backport 3 BCM5301X patches from Hauke repo
[openwrt/svn-archive/archive.git] / target / linux / bcm53xx / patches-3.14 / 320-ARM-BCM5301X-Add-DT-for-Buffalo-WZR-900DHP.patch
index 96c728dfb0d603ca7a6f1187ee6d7e7a57879bd0..b0d0540c3c75090fbe91cd5a3047c113f4c60a84 100644 (file)
@@ -13,11 +13,9 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
  2 files changed, 37 insertions(+), 1 deletion(-)
  create mode 100644 arch/arm/boot/dts/bcm47081-buffalo-wzr-900dhp.dts
 
-diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
-index 64c8f3f..41e8455 100644
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -55,7 +55,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+@@ -56,7 +56,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
        bcm4708-netgear-r6250.dtb \
        bcm4708-netgear-r6300-v2.dtb \
        bcm47081-asus-rt-n18u.dtb \
@@ -27,12 +25,9 @@ index 64c8f3f..41e8455 100644
  dtb-$(CONFIG_ARCH_BERLIN) += \
        berlin2-sony-nsz-gs7.dtb        \
        berlin2cd-google-chromecast.dtb
-diff --git a/arch/arm/boot/dts/bcm47081-buffalo-wzr-900dhp.dts b/arch/arm/boot/dts/bcm47081-buffalo-wzr-900dhp.dts
-new file mode 100644
-index 0000000..5e4b3a9
 --- /dev/null
 +++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-900dhp.dts
-@@ -0,0 +1,35 @@
+@@ -0,0 +1,36 @@
 +/*
 + * Broadcom BCM470X / BCM5301X ARM platform code.
 + * DTS for Buffalo WZR-900DHP
@@ -51,11 +46,12 @@ index 0000000..5e4b3a9
 +      model = "Buffalo WZR-900DHP (BCM47081)";
 +
 +      chosen {
-+              bootargs = "console=ttyS0,115200";
++              bootargs = "console=ttyS0,115200 earlyprintk";
 +      };
 +
 +      memory {
-+              reg = <0x00000000 0x08000000>;
++              reg = <0x00000000 0x08000000
++                     0x88000000 0x08000000>;
 +      };
 +
 +      chipcommonA {
@@ -68,6 +64,3 @@ index 0000000..5e4b3a9
 +              };
 +      };
 +};
--- 
-1.8.4.5
-