brcm2708: fix mkdosfs command line options order
[openwrt/svn-archive/archive.git] / target / linux / brcm2708 / image / Makefile
index 6b4cf141a67429eff4c376b30f90f06276d16897..cb5acde48cdae331fdae171ad74fb77ec5ae7c82 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,13 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 include $(INCLUDE_DIR)/host.mk
 
-define Image/Prepare
-       cp $(LINUX_DIR)/arch/arm/boot/Image $(KDIR)/Image
-endef
-
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
 define Image/Build/RaspberryPi
        rm -f $(KDIR)/boot.img
 
-       mkdosfs $(KDIR)/boot.img -C $(FAT32_BLOCKS)
+       mkdosfs -C $(KDIR)/boot.img $(FAT32_BLOCKS)
        # Raspberry Pi has no bootloader, instead the GPU loads and starts the kernel
        mcopy -i $(KDIR)/boot.img $(BUILD_DIR)/brcm2708-gpu-fw-boot/bootcode.bin ::
        mcopy -i $(KDIR)/boot.img $(BUILD_DIR)/brcm2708-gpu-fw-boot/COPYING.linux ::