2.6.22 is released :)
[openwrt/svn-archive/archive.git] / target / linux / brcm47xx-2.6 / Makefile
index ca7fd5d2d1cbdf54834693e997686598f1e895fc..fcf404aab67e0533d7a801f8f414a4869f097a5e 100644 (file)
@@ -8,15 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=brcm47xx
-BOARDNAME:=Broadcom BCM947xx/953xx (new code)
-FEATURES:=squashfs broken
+BOARDNAME:=Broadcom BCM947xx/953xx
+FEATURES:=squashfs usb
+
+LINUX_VERSION:=2.6.22
 
 define Target/Description
        Build firmware images for Broadcom based routers
-       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
+       (e.g. Netgear WGT634U)
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
-# DEFAULT_PACKAGES += kmod-switch
+DEFAULT_PACKAGES += kmod-switch kmod-diag
+
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))