set the kernel version of brcm47xx-2.6 in the target makefile, keep patch compatibili...
[openwrt/svn-archive/archive.git] / target / linux / brcm47xx-2.6 / patches / 110-flash_map.patch
index 74fe01a25f0201bcf2edf56e92d04ae8c2ff4865..13f36c2914bb2fabe9ab9a53ae69457666f49f53 100644 (file)
@@ -1,8 +1,7 @@
-Index: linux-2.6.22-rc4/drivers/mtd/maps/Kconfig
-===================================================================
---- linux-2.6.22-rc4.orig/drivers/mtd/maps/Kconfig     2007-06-10 21:32:13.000000000 +0100
-+++ linux-2.6.22-rc4/drivers/mtd/maps/Kconfig  2007-06-10 21:33:14.000000000 +0100
-@@ -358,6 +358,12 @@
+diff -urN linux.old/drivers/mtd/maps/Kconfig linux.dev/drivers/mtd/maps/Kconfig
+--- linux.old/drivers/mtd/maps/Kconfig 2006-12-11 20:32:53.000000000 +0100
++++ linux.dev/drivers/mtd/maps/Kconfig 2007-01-03 02:26:02.000000000 +0100
+@@ -326,6 +326,12 @@
          Mapping for the Flaga digital module. If you don't have one, ignore
          this setting.
  
@@ -12,14 +11,13 @@ Index: linux-2.6.22-rc4/drivers/mtd/maps/Kconfig
 +      help
 +        Support for the flash chips on the BCM947xx board.
 +        
- config MTD_WALNUT
-       tristate "Flash device mapped on IBM 405GP Walnut"
-       depends on MTD_JEDECPROBE && WALNUT
-Index: linux-2.6.22-rc4/drivers/mtd/maps/Makefile
-===================================================================
---- linux-2.6.22-rc4.orig/drivers/mtd/maps/Makefile    2007-06-10 21:32:13.000000000 +0100
-+++ linux-2.6.22-rc4/drivers/mtd/maps/Makefile 2007-06-10 21:33:14.000000000 +0100
-@@ -33,6 +33,7 @@
+ config MTD_BEECH
+       tristate "CFI Flash device mapped on IBM 405LP Beech"
+       depends on MTD_CFI && BEECH
+diff -urN linux.old/drivers/mtd/maps/Makefile linux.dev/drivers/mtd/maps/Makefile
+--- linux.old/drivers/mtd/maps/Makefile        2006-12-11 20:32:53.000000000 +0100
++++ linux.dev/drivers/mtd/maps/Makefile        2007-01-03 02:26:02.000000000 +0100
+@@ -31,6 +31,7 @@
  obj-$(CONFIG_MTD_PCMCIA)      += pcmciamtd.o
  obj-$(CONFIG_MTD_RPXLITE)     += rpxlite.o
  obj-$(CONFIG_MTD_TQM8XXL)     += tqm8xxl.o
@@ -27,3 +25,4 @@ Index: linux-2.6.22-rc4/drivers/mtd/maps/Makefile
  obj-$(CONFIG_MTD_SA1100)      += sa1100-flash.o
  obj-$(CONFIG_MTD_IPAQ)                += ipaq-flash.o
  obj-$(CONFIG_MTD_SBC_GXX)     += sbc_gxx.o
+