new upstream kernel 2.6.28.6
[openwrt/svn-archive/archive.git] / target / linux / brcm47xx / Makefile
index 11485fe056e84f9532a73b7a317a31e1c33ce024..60ddb7e0b4ea53fed6d0ab565222d78cd967d825 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,17 +11,14 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.28.6
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += hostapd-mini kmod-switch kmod-diag
 
 define Target/Description
        Build firmware images for Broadcom based routers
        (e.g. Netgear WGT634U)
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
-
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))